"Christmas - the time to fix the computers of your loved ones" « Lord Wyrm

Laufwerkbuchstabe für USB Device

hynk 12.01.2019 - 22:22 238 3
Posts

hynk

Super Moderator
like totally ambivalent
Avatar
Registered: Apr 2003
Location: Linz
Posts: 9908
Steh gerade vor einem seltsamen Problem.
Hab hier eine Micro SD Karte in einem Galaxy S9 (fungiert als Card Reader weil keiner zur Hand ist) und will die Daten runtersichern. Es handelt sich um einen Haufen Files und nach einer undefinierbaren Menge bricht der Kopiervorgang ab. Egal, also kopier ich einfach mal manuell nach dem Alphabet (Folders beginnend mit A, B, C, erc der Reihe nach). Nur leider hab ich am Ende nicht die selbe Anzahl Files. Zu dem Zweck dachte ich mir pack ich copy-item in Powershell aus. Nur leider ist die SD Karte bzw das USB Device weder im Disk Management auffindbar, noch gibts einen Laufwerksbuchstaben.
Angeschlossen ist das Galaxy mit dem einzigen USB-C Kabel am einzigen USB-C Port. Also gibts da auch kein umstecken :D

Irgendwelche Ideen wie ich das Handy oder die Karte mounten kann um sie in Powershell anzusprechen? Hab auch schon Allwaysync probiert, da scheint der Device aber auch nicht auf.

Das Problem scheint bekannt zu sein, nur find ich keine brauchbare Lösung.

tia!

*edit
Die Files sind jetzt mal sicher nachdem ich nochmal alle Ordner manuell kontrolliert habe, die Frage würd ich trotzdem gern klären :)

spunz

Super Moderator
tot durch snu-snu
Avatar
Registered: Aug 2000
Location: achse des bösen
Posts: 10166
wird wohl eine PTP/MTP Verbindung sein, da gibts Bastellösungen wie "ptpdrive" um das ganze als Laufwerk zu mounten. Ob der Kram dann stabiler läuft ist eine andere Frage :)

xtrm

social assassin
Avatar
Registered: Jul 2002
Location:
Posts: 7204
Mich würde eher interessieren, welche files nicht mitkopiert werden - für die Daten relevante sollten es jedenfalls nicht sein.

hynk

Super Moderator
like totally ambivalent
Avatar
Registered: Apr 2003
Location: Linz
Posts: 9908
Danke spunz, probier ich mal.

Der Kopiervorgang wurde einfach nach einiger Zeit abgebrochen ohne irgendeiner Meldung, als wär alles gut gegangen. Die Files waren eine Ordnerebene weiter unten als sonst wo und waren sich wiederholende Ordnernamen. zB: X:\Musik\Artist\Album1\Album1\Track.mp3

Trotzdem seltsam, dass er manche Files kopiert hat und andere einfach ignoriert hat. Oder eben einfach angelegt, aber nicht zur gänze kopiert. Werd mir morgen mal einen Cardreader besorgen und das Ding durchchecken. Gefühlt hat mir der Kollege die SD gerade zur richtigen Zeit geliehen. Hat sicher nirgends ein Backup :D
Kontakt | Unser Forum | Über overclockers.at | Impressum | Datenschutz